85122 - ECHO/PULSE - After installation Windows Livescribe Desktop does not run

I installed Windows Livescribe Desktop successfully but when I try to run the software nothing happens.

If your Windows Livescribe Desktop installation was successful but when you double-click on the Livescribe Desktop icon your mouse cursor changes for a few seconds but then nothing happens, you may be missing a required Windows system font.  

To verify this:

  1. Click on your Windows "Start" button.
  2. Open "Control Panel".
  3. Open "Fonts".  NOTE:  Windows 7 users will need to double-click on the "Abg" Arial icon.
  4. Look for the font titled "Arial Regular" (Windows 7) / "Arial" (Windows Vista and XP).
  5. If "Arial Regular"/"Arial" does not appear then go to the Microsoft page http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=16083.
  6. Click the "Download" button.
  7. Save the "EUupdate.EXE" file.
  8. Double-click and Run the file.
  9. After accepting Microsoft's terms the fonts will be installed. 
  10. Click "OK"

Now "Control Panel > Fonts" should show the "Arial Regular"/"Arial" font.  Try running Livescribe Desktop again and this should resolve the problem.

If you still have an issue please send us your log files by accessing 201012 - Windows - Critical error at startup. Unable to get Log Files using Livescribe Desktop.

Did this answer your question? Thanks for the feedback There was a problem submitting your feedback. Please try again later.

Still need help? Contact Us Contact Us